Back to overview
Downtime

Marketing Site Unavailable

Apr 2, 2026 at 7:15pm UTC
Affected services
nc.nuvoclaims.com

Resolved
Apr 2, 2026 at 7:18pm UTC

The issue affecting nc.nuvoclaims.com has been resolved. Our marketing site is fully accessible again. This outage was caused by a service disruption at our hosting provider, Squarespace, and was outside of our control. We apologize for any inconvenience.

Created
Apr 2, 2026 at 7:15pm UTC

We are currently experiencing an outage affecting our marketing site at nc.nuvoclaims.com. The site is hosted on Squarespace and we have identified the issue as originating with our hosting provider. Our team is monitoring the situation. All claims administration services and the Nuvo Claims platform remain fully operational and unaffected.